(updated) We had a problem with the broadband. I know exactly when because when the storms of 26th June hit the broadband went down and came back at a very slow rate. It went from 15Mb connected (12Mb or so usable) to just 700k, then bounced about and eventually settled at around 2Mb. A line test via the NowTV website told us what we knew – the broadband was slow. Too late by then for their customer services I rang the next day which was a Saturday. They ran a test which actually got us back to 8Mb or so but that didn’t last. Anyway, they arranged for OpenReach to come and check the line. Clearly storm related I had wondered if water had got at the terminals on the pole outside or a duct had flooded somewhere and water had got into the cable, but if the latter you’d expect many customers to be affected.

OpenReach came two days later and discovered that our wire pair had been trapped by the junction box lid. That was fixed and we then got a 16Mb connection, the best it had ever been. That lasted a couple of days.

Then, oddly at around 2.45 each morning the router would reset and the line would come back 2Mb slower. It went from 16Mb to 14, 10, 12 and now 8Mb. Rebooting the router had no effect. And now the line test via NowTV’s website does not even work. After saving the router settings to file I did a full router reboot in case something had gone funny. Bad move! First, I forgot that the router comes back as 192.168.0.0 and our LAN is not 0. When I figured that out I tried to access via the Mac and wifi but the server would not stop sending the wrong IP address (or, rather the correct one which now had no chance of working). Of course I have another wifi hub and it was getting the IP that way. Shutting that down and toggling wifi got me back in so I could change the subnet address and get back in via the wired PC that had the saved router settings file. Ok… so simple, right? Reload the settings and all will be well. No. The router will NOT reload the file! Fortunately there are not many settings so I put those back in by hand. 

NowTV customer service are good at arranging things. They organised Openreach to re-visit. The speed had dropped to 4Mb when they arrived. After a lot of testing they found that the wires were ok and to giving errors and a new router was sent by NowTV. They said that if there are errors the exchange equipment falls back progressively to compensate and it was our router at the source of the issue, well that and the original line fault. So far, so good, and we’re back to a 15Mb connection which gives 12Mb+ usable bandwidth.